استفسار help me in java problem ,,,

الموضوع في 'قسم الكومبيوتر العام ( حل مشاكل - تبادل خبرات )' بواسطة jebreen, بتاريخ ‏يونيو 11, 2016.

  1. jebreen

    jebreen Active Member

    إنضم إلينا في:
    ‏يونيو 10, 2009
    المشاركات:
    162
    الإعجابات المتلقاة:
    54
    نقاط الجوائز:
    28


    I have mac EL Capitan, 10.11.5, I used RWeka package, it downloaded correctly and initialized with any error, but when I apply

    J48(Species~., data = iris)
    I have this error

    Error in .jnew("weka/core/Attribute", attname,.jcast(levels,"java/util/List")): java.lang.UnsupportedClassVersionError: weka/core/Attribute:Unsupported major.minor version 51.0

    I used java version with these details,

    52F85:~ kameljabreen$ java -version java version "1.7.0_79"Java(TM) SE RuntimeEnvironment(build 1.7.0_79-b15)JavaHotSpot(TM)64-BitServer VM (build 24.79-b02, mixed mode)
    Please help me to solve this problems, it is my problm since one month, I read a lot about this problem in web sites. I did all thing, installing java JDK version 1.8 .... ect. now I used java 1.7. Please give me solutions. Thanks in advance

مشاركة هذه الصفحة